Must be run on a Sharepoint/WSS server

Apr 27, 2011 at 11:12 AM

Hi,

Trying SPWakeUp on 2008 R2 with sharepoint Foundation give me this :

Started running at 27/04/2011 12:05:45
Running on the system 2008R2
Setting verbose mode.
Trouble getting handle on Sharepoint Farm. Must be run on a Sharepoint/WSS server.

Any idea ?

 

Thanks

Aug 30, 2011 at 2:23 PM

Hey,

You will need to run the script using the SharePoint Farm Account, this will have the necessary permissions for it to execute.

E.g. open cmd "Run as different user"

You will then see SPWakeUp run through the respective site collections on each web application, adding and waking as it goes.

If you have a schedule running to execute the script each day, make sure you assign the FARM account: "When running the task, use the following user account". It is also important to disable User Account Controls, as this can prevent the script from executing. 

Hope this helps!

Oct 18, 2011 at 2:12 PM

I am having the same issue except that I already have UAC disabled and am running from a FARM account.  It will run fine from command line, but not as a scheduled task.  I believe the issue might be because I have to check the "Do not store password.  The task will only have access to local computer resources."  Our GPO does not allow caching of the user credentials.  I thought we should be able to use the command line passing of credentials to get around this.  Is this a restriction of this code?  Do I have to cache the user credentials for a scheduled task?  And if so, is this just he latest rev?  Would an earlier version work?

Oct 19, 2011 at 3:39 PM

I'm afraid that you are correct about the need to store the credentials.  There is an option to pass the tool a login name and password, but I'm afraid this is only used to authenticate to the web server.  To build the list of sites, the tool will need the farm account's credentials.

You could try the very first version of this tool.  That version parses everything through stsadm commands, and may work without credentials.  This version is much slower that later versions, but if you're running this as a scheduled task, that shouldn't be much of a problem.

Oct 19, 2011 at 9:30 PM

I tried version 2.4 and even with -nodiscover, -site, -username, -password specified it runs fine from command line but not the scheduled task.  I can't figure out how to get around this.  It is a standard security GPO to disallow caching of credentials.  What good are passing the credentials if when run as a task this will always require the credentials to be cached?  This is simply to reproduce.  Do you have any suggestions?