SharePoint 2013 version

Jan 5, 2013 at 3:25 PM

I've compiled SPWakeUp3 using the RTM SharePoint 2013 DLLs; a copy is available from https://skydrive.live.com/redir?resid=439F1389F21A368F!1171

Andy

Mar 14, 2013 at 7:12 PM
Would you mind letting me know what DDLs you needed to replace to get this to work? I don't think I trust a random exe compiled and shared via skydrive. I'd prefer to compile the exe myself from the source provided here with the necessary DLLs.

Thank you
Mar 15, 2013 at 9:08 AM
Edited Mar 15, 2013 at 9:22 AM
The only thing you need to change is to remove the reference to the original Microsoft.SharePoint.dll file and replace it with the one from SharePoint 2013 and recompile. There are however 2 microsoft.SharePoint.dll files on a SharePoint 2013 computer, you want the one from:

C:\program Files\Common Files\Microsoft Shared\Web Server Extensions\15\ISAPI

Take a copy of the dll, and put it into the solution folder somewhere, then add a reference to it in the project replacing the original reference, then recompile and you should be good to go. Hopefully it should be a binary match for mine!

Note that I used VS 2010, not VS 2012, I've not tried upgrading the project into VS 2012 yet.

Andy
Mar 15, 2013 at 6:38 PM
I was able to replace the dll (I also needed Microsoft.SharePoint.Library.dll) and got the file to compile in VS 2012.

I know the difference is because of the VS versions but here are the MD5 hashes for the 3.0a version hosted here on codeplex. The one you compiled in VS 2010, and the one I compiled in VS 2012

SPWakeup3
5D53924DC05C5D15C33D1097D40B5534
SPWakeup3_2013 (VS 2010)
4D36821B171BE1EA22420C50DBF84B8D
SPWakeup3_2013 (VS 2012)
A5BF5DEEFC7B3A9826B025F474FD044C

My only problem now is even with valid login credentials (I can log into the site with the same credentials) I get a 401 unauthorized error for every URL.
Mar 15, 2013 at 8:35 PM
I am not a developer and did the bare minimum to get the solution working with VS 2010 and cannot comment on what would be required for it to work with VS 2012 (perhaps the SPWakeup3 team could produce a new official version?)
The original SPWakeup3 appears to have been compiled against the 2007 Microsoft.SharePoint.dll.

As far as testing the newly compiled version of SPWakeup3, are you performing your tests on the server console and logging into the site (presumably using IE) on the server console as well? If you're testing the SPWakeup3 exe on the server console but logging into the site from another PC, you might be hitting an issue on the server with the loopback check. See http://support.microsoft.com/kb/896861 for information about disabling the loopback check and then try again.

Andy
Mar 15, 2013 at 8:53 PM
I've just compiled a version using VS 2012. I opened the solution in VS2012 and allowed the conversion to complete, then replaced the reference to Microsoft.SharePoint.dll with one pointing to the SharePoint 2013 version. I then changed the version of .NET that the solution would be targeted against and built the solution.

The version I got (the debug build) was 18kb.

I've just run it on a test SharePoint 2013 farm and it appears to work correctly.

Andy
Mar 15, 2013 at 9:30 PM
Thank you for the link to the article I did find that link elsewhere in the forum and am taking steps to test if that fix will work for me. The Method 1 solution was not clear about the "host names for the sites that are on the local computer". Are they asking for http://mysharepointserverurl.com or hostname of the machine sharepoint-server? I tried both with the same result. I also tried with a wildcard http://mysharepointserverurl.com/* and had the same result. I am going to test disabling the check but will need to schedule a reboot for the server.
Mar 16, 2013 at 10:11 AM
The host name is the base URL of the web application without any protocol information, so if the site is accessible on http://intranet.domain.com then the host name would simply be:

intranet.domain.com

Andy
Mar 16, 2013 at 10:41 AM
Edited Mar 18, 2013 at 4:46 PM
After adding the registry value with my hostname and restarting the iis admin service I still get the same 401 error. I tried adding the disableloopbackcheck registry value and restarted the web server and now get "Error getting subwebs" along with error 401.

Thanks for you help but I think I'll try to do this another way.
Apr 23, 2013 at 2:31 AM
Thanks so much @LittleAndy - your SPWakeup_2013.exe is working nicely on my upgraded SharePoint 2013 RTM server.

Are there plans to make this an official download for this project?

PS: I love this project - it's so simple and elegant compared to any other alternative I've seen/tried.

Thanks
Mike
Jul 26, 2013 at 7:28 PM
Hi,
I got error when I run the SPwakeup2_2013. it says:cannot get handle on sharePoint farm.
Can anyone gave a sample how to run it?

Thanks
Jul 26, 2013 at 7:38 PM
Hi,
I downloaded one copy from skydrive. And run it like below at command line on one of my webserver
spwakeup3_2013.exe -email:xx@xxx.com -username:Web1Svc -Domain:cp -Password:WebB!PWeb1Svc0430. I for error:
I got error:
Trouble getting handle on Sharepoint Farm. Must be run on a Sharepoint/WSS servr.
Error sending email, could not find working site.

what I did wrong? Please help!

Thanks