SPWakeUp does not appear to work on Server 2k8? (Problem has been fixed)

Sep 14, 2008 at 11:25 PM

I have tried to run spwakrup on a win2k8 machine and I keep getting the following error...
SPWakeUp has stopped working...
and then this is throwen in the cmd window.
Unhandled Exception: System.IO.FileNotFoundException: The Web application at htt
p://servername could not be found. Verify that you hav
e typed the URL correctly. If the URL should be serving existing content, the sy
stem administrator may need to add a new request URL mapping to the intended app
   at Microsoft.SharePoint.SPSite..ctor(SPFarm farm, Uri requestUri, Boolean con
textSite, SPUserToken userToken)
   at Microsoft.SharePoint.SPSite..ctor(String requestUrl)
   at SPWakeUp.Program.BuildSiteList(ArrayList list)
   at SPWakeUp.Program.Main(String[] args)

SPWakeUp.exe -verbose -log:c:\log.txt

I can confirm that I can hit the site directly on the machine from the same user that i am logged into windows with. Has anyone else tried running this on a 2k8machine?
Any ideas?
Sep 15, 2008 at 1:52 AM
Try specifying the full server address using the option -site:http://server.domain.com.   I think the error you're running into is the localhost bug I mentioned in the release notes.  I'm hoping to have some time to work on this problem tomorrow.

Please let me know if this helps.  If you're still running into trouble, you might want to go download the previous version until I get all these kinks worked out.
Sep 16, 2008 at 11:14 PM

Thanks for the new version it now works a treat. Ran SPWakeUp.exe -discover -verbose -log:c:\spwakeup.log.