Unable to run as a scheduled task

Feb 26, 2009 at 8:07 PM
I get a message of unable to start whenI try to run this as a scheduled task it works OK if i just run it by double clicking

I am using the same account in both scearios.
I have other scheduled tasks which run OK

Mar 16, 2009 at 11:16 PM
Edited Mar 17, 2009 at 2:07 AM
Perhaps there aren't enough permissions under that service account that you are running the task under -- have you tried to create a .cmd file with something arbitrary in it to verify that stsadm can run under the permissions you've granted that account?

stsadm -o enumsubwebs -url http://yoursite  > logfile.txt 2> errorlogfile.txt

So I needed to do the same thing, and I suspect everyone who downloads this tool will need to as well.  Here is my working configuration:

1. create a cmd wrapper -


set timeFileExtension=%Date:~-4,4%%Date:~-10,2%%Date:~-7,2%T%Time:~0,2%%Time:~3,2%

spwakeup -log:spwakeup_%timeFileExtension%.txt 2> spwakeup_err_%timeFileExtension%.txt


2.  create a task in Task scheduler.  Windows 2008 options:
- General > run whether the user is logged on or not
- Triggers > daily, at 1:15am every day
- Triggers > at startup, at system startup
- Action > start a program | c:\filepath\spwakeupwrapper.cmd  |  arguments: 1> at-std-out.txt  2> at-std-err.txt   |  start in:  c:\filepath
- I have this task running under the sharepoint setup account login, which is part of the local group wss_admin_wpg, but I believe any account under that local group may work fine.

3. try running the scheduled task interactively, and check those files such as at-std-err.txt, which will keep any error detail beyond what is recorded in the event viewer..

Please post back if you get it to work.

Mar 28, 2009 at 8:35 PM
tried to add regular user to wss_admin_wpg group but no luck. Is there a way to be ~22visitor~22 and use this tool~3f~3cbr /~3e ~3cbr /~3e ~3cbr /~3e
Apr 14, 2009 at 8:39 AM
I am also having the above probplem. When I try to run spwakeup at a command prompt I get the following:

C:\Program Files\SpWakeUp>SPWakeUp.exe
Access is denied.

C:\Program Files\SpWakeUp>SPWakeUp.exe -help
Access is denied.

C:\Program Files\SpWakeUp>


Is anyone able to tell me the specific permissions required to run spwakeup - I am deliberately trying to run this as a non-admin user.

Apr 14, 2009 at 9:21 AM

Sorry - I have found the solution to this. When I downloaded spwakeup I did so to my desktop (as an admin) and then moved it into the Program Files folder. As a result it retained the permissions from when it was on the desktop. This did not inlcude the NTFS Execute permission for non-admin users.

Re-setting NTFS permissions on spwakeup to inherited resolved the problem.