Error: Cannot reach site

Apr 28, 2009 at 6:19 PM
I have downloaded the product.  Seems great.  I really want this to work. 

I have properly configured the exclusion file and the inclusion file.  I can run the app and it properly configures the adding sites from what I can tell.  I am running it as the setup user (god rights to all collections) but it doesnt seem to work.  Two errors that I can see:

All sites get added and then it rescans all the root sites and names them as subsites as well.  Odd but I dont mind as long as it works.

Every site that is added is then attempted to be "woken" up.  However every site errors out with the "Cannot Reach Site: Http://"

I know I am logged in as the sharepoint setup account on the sharepoint server where I am running this.  I tried this from a scheduled task, batch file, and from the commandline manually.  Everything seems to work excepting the darn wake up.  Any help would be appreciated.

May 10, 2009 at 8:36 PM

Hi Eric,


same here. However: SPWakeUp worked fine for my MOSS SP1 farm. But since I installed SP2 a couple of days ago, I also get the "Cannot reach side". For me it looks like SPWakeUp is incompatible with MOSS SP2.

I am sad to see that such a useful tool ceased working :-(



May 11, 2009 at 2:45 PM

Hmm, sorry to hear that you're both having problems.  Are either of your using Forms Authentication by any chance?  I haven't been able to get that working, so currently the utility only works with NTLM authentication.

I've been testing it on my own systems which are SP2, and haven't had any problems with the new version.  Can you send me a few details about your server environment, and a copy of any error messages that pop up?  I'll see if I can reproduce what you're seeing and (hopefully) come up with a fix.

May 11, 2009 at 9:07 PM

Well, during my tests after installing SP2 I noticed that SPWakeUp did not work any more - leading me to above conclusion. Logs are pretty unspectacular:


Found 52 Site Collections.
Waking up 101 sites.
Waking up
Error: could not be reached
Waking up
Cannot reach site:


When I start SPWakeUp from command line with the -verbose switch I see that first all sites within all Site Collections are successfully enumerated.

That's all debugging info I could turn on in SpWakeUp. Can you make anything out of it? Could I try anything else? SPWakeUp is even running under the Secondary Administer account for all Site Collections ...



May 18, 2009 at 10:14 AM

I have the same problem. I have 2 WFE servers and it works on one but not the other:

Verbose mode set to on.
Web Application discovery set to off.
Found 1 Site Collections.
Waking up 1 sites.
Waking up http://webAddress
Error: http://webAddress could not be reached

The farm is running SP2. I have edited the hosts file to point the servers to themselves. I can connect to the URL on either server from my laptop and locally using the WebAddress so I know the URL is valid.

I have found this in the Application event log just after the scheduled task is run:

Event Type: Warning
Event Source: ASP.NET 2.0.50727.0
Event Category: Web Event
Event ID: 1309
Date:  5/18/2009
Time:  2:03:08 AM
User:  N/A
Computer: ServerName

Event code: 3001
Event message: The request has been aborted.
Event time: 5/18/2009 2:03:08 AM
Event time (UTC): 5/18/2009 1:03:08 AM
Event ID: 6201947c530f41c3b5d8d735d49ad120
Event sequence: 3
Event occurrence: 1
Event detail code: 0
Application information:
    Application domain: /LM/W3SVC/1159392139/Root-1-128870820379462534
    Trust level: WSS_Minimal
    Application Virtual Path: /
    Application Path: F:\Data\inethost\ITSME\
    Machine name: ServerName 
Process information:
    Process ID: 5608
    Process name: w3wp.exe
    Account name: Domain\FarmServiceAccount 
Exception information:
    Exception type: HttpException
    Exception message: Request timed out.
Request information:
    Request URL: http://WebAddress
    Request path: /default.aspx
    User host address: (IPAddress) 
    User: Domain\FarmServiceAccount 
    Is authenticated: True
    Authentication Type: NTLM
    Thread account name: Domain\FarmServiceAccount 
Thread information:
    Thread ID: 1
    Thread account name: Domain\FarmServiceAccount
    Is impersonating: False
    Stack trace:
Custom event details:

For more information, see Help and Support Center at

Could this be caused by a timeout?



May 20, 2009 at 9:48 AM

Looks like this could be a timeout issue. If I run the scheduked task again 5 mins later it works.

May 22, 2009 at 6:56 PM

Thanks to everyone who is posting details on this problem.  I'm continuing to try to reproduce the problem on my own test servers without any luck so far.  I'll see if there is something I can do to increase any time-out limitations.

Jun 3, 2009 at 3:04 PM

I have recieved the same errors. could it have anything to do with host headers? On my VMs that do not use host headers it seems to work fine, but on those with HH - I get the sites enumerated, but they cannot be reached.

Jun 3, 2009 at 3:32 PM

well I am using host headers too.  They get enemerated but cannot be reached either

Jun 10, 2009 at 2:32 AM


I was also confronted by this issue. After a bit of poking around I found heaps of 537 events in the Security event logs. I then disabled the loopback check and it works fine now, I hope this helps to solve some of the similar issues that appear to be facing some users.

Jun 10, 2009 at 5:58 PM

How did you disable the loopback check?  I'm not familiar with this.

Jun 11, 2009 at 12:43 AM

Here is the link...

I tried Method 1 but it didn't work for me... so I used Method 2!

Jun 23, 2009 at 6:33 PM

Thanks - that reghack does seem to have fixed the problem.

Jun 28, 2009 at 12:26 AM

Praise eezz (and akennel, of course ;-) Method 2 of kb896861 solved it for me too!

Jun 29, 2009 at 9:57 AM

By the way, the same issue caused caused all crawls to fail on sites with names other than the native host name of the sharepoint server. So, sharepoint search was affected by the same issue.